summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/polybar/Manifest1
-rw-r--r--x11-misc/polybar/polybar-3.2.1.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/x11-misc/polybar/Manifest b/x11-misc/polybar/Manifest
index e9570d0e6699..d4f83e2bd945 100644
--- a/x11-misc/polybar/Manifest
+++ b/x11-misc/polybar/Manifest
@@ -1,4 +1,3 @@
DIST i3ipcpp-0.7.1.tar.gz 191417 BLAKE2B 62b76a0921c78f374309d26856c01d1467b8bd181ce922fd47daec406afda9d76eea9a1f473b4899e22f99e2ef36fc70f72db1bb17eb1f3e71a8431c2634b915 SHA512 ef9f591bb4436916ad038bcb0c15ea3415d1978ff264fb276108ddac89c98515c464fbf252429f6a76589cb78e1434adba2efefb5a844dadad0e261f3806fb72
-DIST polybar-3.2.1.tar.gz 242327 BLAKE2B eb7bfe6e6d58fb4389016b8e5c73feea3984ce3ccefdb1acf202c6d2873a634e4d096658b850e8534c5c8c56e42ac66b3b8e80dabf5625491e5f56523b043ddf SHA512 e93c33738029b2e56a5dda75cbf3ee804c0d89c406444da6991ea8a5dd00e5544ef51d20f3d67ec293fc55ab7095e8e3057aaf8d1c08af61cf0531297e55a18d
DIST polybar-3.3.1.tar.gz 248790 BLAKE2B 30c2cd2ff537f3a2fe2fe7ce489b5a0ab76a54cd42bbdf8b3727e5f4298898e289c6ea10a460385d8bcdc8ab11749255573bf7d728a01eae895a1ed8a2214c27 SHA512 c0bfaf99dcd19f8fcca8bd041c0f9e5f11fb822c92cf12edc2c59e67896f566ee46d1a0d75f5583d393af3a1958c3244a4eb28224f6336e9eaa98a50d740f834
DIST xpp-1.4.0.tar.gz 84095 BLAKE2B 2af4221953abe7f40473c55cd50c608b54ebc85a62be65af987ed5e6c5eaf56fbd92531788becf39ba5ad52099ac78f36e9b2a2515b473f4d86ed5fda3fa5065 SHA512 d34cbbe2391db36db7dffac0415d26b7487536e97c4d7efd472ab0aeffa4c8e757ee030b05e2aa1cfa8a591ee591bb96a6db7eb9fa5850027f958e92f078739c
diff --git a/x11-misc/polybar/polybar-3.2.1.ebuild b/x11-misc/polybar/polybar-3.2.1.ebuild
deleted file mode 100644
index 480c094886de..000000000000
--- a/x11-misc/polybar/polybar-3.2.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-XPP_VERSION="1.4.0"
-I3IPCPP_VERSION="0.7.1"
-
-DESCRIPTION="A fast and easy-to-use tool for creating status bars"
-HOMEPAGE="https://github.com/jaagr/polybar"
-SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
- https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="alsa curl i3wm ipc mpd network pulseaudio"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- x11-base/xcb-proto
- x11-libs/cairo[xcb]
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/xcb-util-xrm
- alsa? ( media-libs/alsa-lib )
- curl? ( net-misc/curl )
- i3wm? ( dev-libs/jsoncpp )
- mpd? ( media-libs/libmpdclient )
- network? ( net-wireless/wireless-tools )
- pulseaudio? ( media-sound/pulseaudio )
-"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- rmdir "${S}"/lib/xpp || die
- mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
-
- rmdir "${S}"/lib/i3ipcpp || die
- mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
-
- sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_ALSA="$(usex alsa)"
- -DENABLE_CURL="$(usex curl)"
- -DENABLE_I3="$(usex i3wm)"
- -DBUILD_IPC_MSG="$(usex ipc)"
- -DENABLE_MPD="$(usex mpd)"
- -DENABLE_NETWORK="$(usex network)"
- -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
- )
- cmake-utils_src_configure
-}