summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild27
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild27
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
new file mode 100644
index 000000000000..1e0ef374a717
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
new file mode 100644
index 000000000000..1e0ef374a717
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}