summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/2mandvd/2mandvd-1.8.5.ebuild67
-rw-r--r--media-video/2mandvd/Manifest1
-rw-r--r--media-video/2mandvd/files/2mandvd-1.7.3-libav.patch10
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch32
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch21
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch27
-rw-r--r--media-video/2mandvd/metadata.xml15
-rw-r--r--profiles/package.mask5
8 files changed, 0 insertions, 178 deletions
diff --git a/media-video/2mandvd/2mandvd-1.8.5.ebuild b/media-video/2mandvd/2mandvd-1.8.5.ebuild
deleted file mode 100644
index f272c5b4e872..000000000000
--- a/media-video/2mandvd/2mandvd-1.8.5.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-LANGS="cs de en it ru"
-
-inherit qt4-r2
-
-MY_PN="2ManDVD"
-
-DESCRIPTION="The successor of ManDVD"
-HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
-SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug libav"
-
-DEPEND="libav? ( media-video/libav:= )
- !libav? ( media-video/ffmpeg:0= )
- media-libs/libsdl
- virtual/glu
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
-"
-RDEPEND="${DEPEND}
- || ( app-cdr/cdrkit app-cdr/cdrtools )
- dev-lang/perl
- media-fonts/dejavu
- media-gfx/exif
- media-libs/netpbm
- media-sound/sox
- media-video/dvdauthor
- media-video/ffmpegthumbnailer
- media-video/mjpegtools
- media-video/mplayer[encode]
-"
-
-S=${WORKDIR}/${MY_PN}
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.7.3-libav.patch"
- "${FILESDIR}/${PN}-1.8.5-libavformat54.patch"
- "${FILESDIR}/${PN}-1.8.5-gcc6.patch"
- "${FILESDIR}/${PN}-1.8.5-ffmpeg3.patch"
-)
-
-src_prepare() {
- # Clean backup files
- find . -name "*~" -delete || die
-
- # Delete useless chmod that violates the sandbox
- sed -i -e '/chmod/d' ${MY_PN}.pro || die
-
- # Fix desktop file
- sed -i -e '/^Categories=/s/GNOME;AudioVideo;//' ${MY_PN}.desktop || die
-
- qt4-r2_src_prepare
-}
-
-pkg_postinst() {
- elog "You may wish to install media-video/xine-ui and/or build"
- elog "media-sound/sox with USE=mad for improved media handling support."
-}
diff --git a/media-video/2mandvd/Manifest b/media-video/2mandvd/Manifest
deleted file mode 100644
index fa29706110a9..000000000000
--- a/media-video/2mandvd/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST 2ManDVD-1.8.5.tar.gz 29525071 BLAKE2B 7d1a4f8942fe29e29703ea9a13953f587cd482945676ee85dd8643291c3c680e280b12dbd7fe9eabecf2883251ce4ebede6a66154859ae5f65f7b83d8bbb642f SHA512 1e43034cab310ce0a642afdfcb2b4ddbc47b16b0f353adebd1fd2ec5f8445add41226390c6656e7cb520d9900e1b482adee7adb6f784d2fbfbaff2334feb3284
diff --git a/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch b/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch
deleted file mode 100644
index 59dfd1e33a1e..000000000000
--- a/media-video/2mandvd/files/2mandvd-1.7.3-libav.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- videowrapper.h
-+++ videowrapper.h
-@@ -11,6 +11,7 @@
- #include <libavutil/common.h>
- #include <libavcodec/avcodec.h>
- #include <libavformat/avformat.h>
-+ #include <libavutil/mathematics.h>
- #include <libswscale/swscale.h>
- }
-
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch b/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch
deleted file mode 100644
index 29ffc95ffa82..000000000000
--- a/media-video/2mandvd/files/2mandvd-1.8.5-ffmpeg3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: 2ManDVD/videowrapper.cpp
-===================================================================
---- 2ManDVD.orig/videowrapper.cpp
-+++ 2ManDVD/videowrapper.cpp
-@@ -99,11 +99,11 @@ int videowrapper::load_video(QString fil
-
- img_convert_ctx = sws_getContext(pCodecCtx->width,
- pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,
-- pCodecCtx->height, PIX_FMT_RGB24, SWS_BICUBIC, NULL,
-+ pCodecCtx->height, AV_PIX_FMT_RGB24, SWS_BICUBIC, NULL,
- NULL, NULL);
-
- // *** ON DETERMINE LA TAILLE DU BUFFER ***
-- numBytes=avpicture_get_size(PIX_FMT_RGB24, pCodecCtx->width,
-+ numBytes=avpicture_get_size(AV_PIX_FMT_RGB24, pCodecCtx->width,
- pCodecCtx->height);
- buffer=(uint8_t *)av_malloc(numBytes*sizeof(uint8_t));
- old_frame = -1;
-@@ -120,10 +120,10 @@ QImage videowrapper::read_frame(int64_t
- if ( num_frame != old_frame )
- {
- // *** ALLOCATE VIDEO FRAME ***
-- pFrameRGB=avcodec_alloc_frame();
-- pFrame=avcodec_alloc_frame();
-+ pFrameRGB=av_frame_alloc();
-+ pFrame=av_frame_alloc();
-
-- avpicture_fill((AVPicture *)pFrameRGB, buffer, PIX_FMT_RGB24,
-+ avpicture_fill((AVPicture *)pFrameRGB, buffer, AV_PIX_FMT_RGB24,
- pCodecCtx->width, pCodecCtx->height);
- av_seek_frame(pFormatCtx,videoStream,0, AVSEEK_FLAG_FRAME);
- compte_frame = -1;
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch b/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch
deleted file mode 100644
index 5a16d95ef17f..000000000000
--- a/media-video/2mandvd/files/2mandvd-1.8.5-gcc6.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: 2ManDVD/tetrahedron.h
-===================================================================
---- 2ManDVD.orig/tetrahedron.h
-+++ 2ManDVD/tetrahedron.h
-@@ -83,7 +83,6 @@ public:
- float scale_factor;
- float wg_x;
- float wdecal;
-- GLfloat light_position[];
-
- GLfloat anag_x;
- GLfloat anag_y;
-@@ -427,6 +426,8 @@ private:
- void dropEvent(QDropEvent *);
- void dragEnterEvent(QDragEnterEvent *);
- Qt::DropActions supportedDropActions () const;
-+public:
-+ GLfloat light_position[];
- };
-
- #endif
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch b/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
deleted file mode 100644
index 89ecc4d23c60..000000000000
--- a/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/videowrapper.cpp b/videowrapper.cpp
-index 7ae4ad3..d50599b 100644
---- a/videowrapper.cpp
-+++ b/videowrapper.cpp
-@@ -38,7 +38,7 @@ void videowrapper::delete_videowrapper()
- int videowrapper::load_video(QString filename)
- {
- // *** OUVERTURE DU FICHIER VIDEO ***
-- #ifdef avformat_open_input
-+ #if LIBAVFORMAT_VERSION_INT > AV_VERSION_INT(53,5,0)
- if (avformat_open_input(&pFormatCtx,filename.toAscii().data(),NULL,NULL)!=0)
- {
- #else
-@@ -91,13 +91,8 @@ int videowrapper::load_video(QString filename)
-
- // *** OUVERTURE DU CODEC ***
-
-- #ifdef av_find_stream_info
-- if(avcodec_open(pCodecCtx, pCodec)<0)
-- {
-- #else
- if (avcodec_open2(pCodecCtx, pCodec, NULL) < 0)
- {
-- #endif
- qDebug() << "CAN'T FIND VIDEO CODEC";
- return 1;
- }
diff --git a/media-video/2mandvd/metadata.xml b/media-video/2mandvd/metadata.xml
deleted file mode 100644
index 21d7a2254405..000000000000
--- a/media-video/2mandvd/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
-</maintainer>
-<use>
- <flag name="linguas_cs">Czech locale</flag>
- <flag name="linguas_de">German locale</flag>
- <flag name="linguas_en">English locale</flag>
- <flag name="linguas_it">Italian locale</flag>
- <flag name="linguas_ru">Russian locale</flag>
-</use>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index c817a7a7f85c..8d03fa403909 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -324,11 +324,6 @@ dev-libs/libFuzzer
# testing has been conducted.
=sys-apps/acl-2.2.52-r2
-# Andreas Sturmlechner <asturm@gentoo.org> (09 Jan 2018)
-# Dead upstream, depends on dead Qt4.
-# Bug #643976. Masked for removal in 30 days.
-media-video/2mandvd
-
# Alice Ferrazzi <alicef@gentoo.org> (05 Jan 2018)
# kernel: Meltdown and Spectre - Processor flaw. (#643228)
# Please upgrade for Intel processor flaw workaround