summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-3.0.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 260eb499958a..429468344d64 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -3,3 +3,4 @@ DIST tempora-1.7.tar.gz 11645 BLAKE2B d354fb863a8d30bd9e603ad942d7c7f61a70c24e7f
DIST tempora-2.0.0.tar.gz 19828 BLAKE2B af06f7cfd6742c41fa08333da30bd2b6173affe4d368024122d0464856fa3e2264c85d34505cae023167b4266ed0e927a5a8d620101c02c352cf08b269c8c6b4 SHA512 9f488ecca0673a0071503475378bc8f5ddcfabb32fcc548392434df45767fbeb8b914117622ec6f9dc6a8de90e5bfe6e5571a9a18ddecf7c25e94fc1f7fff102
DIST tempora-2.1.0.tar.gz 21329 BLAKE2B a157a6b9bcb21aac08693ec72e60d011c29d4e6320706186b8a656f096ce19140731e41ca0b7b8b98110a2eed8cee2bfce5ca303b3a7526bbfaec8aafaffff3d SHA512 f66ebf03d5c6d71f1316e3ac9b2c16a96eb622e553917f7e52fe8881cbd5f4651174130e70d2212cad78811859dfb4fe248e6f81a5bb6c928a0c43e9363d2c4e
DIST tempora-2.1.1.tar.gz 21495 BLAKE2B 4300ae55f8c26e0aa55782b9b6a0cb498888cb41d2b80c28ce2093d602821854561b977944eb85e1656998b1734e5975634821060edc3c91ecaf16d5e6dae9cd SHA512 a680ce8b9255e72755beb6e00bfbdd6cb5b76ff4e5b588191c5d263b21cf95e9f717c0fbebb462fbba9a9855e49b4a100c8b41c4ec7d2b8aa44dac75a92679f0
+DIST tempora-3.0.0.tar.gz 21500 BLAKE2B 7bf241d5ab60c78c0ea56df6b28e33504200eb5427cdffaf9d5f34da202c3ba4550fa4dcc48874ee870345fa5a10f2b874687fe7de2bbe049b1c14d05161b0e0 SHA512 2d397c1d17bb4c502817ad0278090137fb8ca00273c63a7336200ed7e621a99cd5c954cdc2da00d06eba34ed4f079429f5ddc68b928cc83feacb2335f995e1b7
diff --git a/dev-python/tempora/tempora-3.0.0.ebuild b/dev-python/tempora/tempora-3.0.0.ebuild
new file mode 100644
index 000000000000..e013b0301a88
--- /dev/null
+++ b/dev-python/tempora/tempora-3.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
+ setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ # Skip a test that requires pytest-freezegun
+ # because it seems to be poorly maintained
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ --deselect tempora/__init__.py::tempora.get_nearest_year_for_day \
+ || die "tests failed with ${EPYTHON}"
+}