summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/libqb/Manifest1
-rw-r--r--sys-cluster/libqb/libqb-1.0.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-cluster/libqb/Manifest b/sys-cluster/libqb/Manifest
index df04572a9a4f..61ac9d1299a9 100644
--- a/sys-cluster/libqb/Manifest
+++ b/sys-cluster/libqb/Manifest
@@ -1,2 +1,3 @@
DIST libqb-0.17.2.tar.xz 373540 BLAKE2B b9d751fca21cc25798a24207740b14722502cbb918cc652cd33b0159a9bd1254a8a64bc73684ae3274a2cf346db5b19924cf010ba487f4c6a9a5f9deade792c4 SHA512 9c6dce7d18aa4da31594faecd0ea2737c2beefa749290094f733fe89ac40f094ec6409f310c534b8144d500e8c204c328386eaf1029995698d7019c014433443
DIST libqb-1.0.1.tar.xz 438204 BLAKE2B be4d4dbe624721a6434f7e3023bcaef017e1358f67fa308e4107bd96469675eca51b5787f498857d22104e3ffa55ded9c44fe320c37fec639a84648c1f517223 SHA512 9afdf5b7064f4e79f70e3c21d1ae954d1444d202d5903bd84866e502b2afc218d4a84fd21fab637a198357e1dad5da94814a6c0bdaa0ba6ac4a24ff40422c185
+DIST libqb-1.0.5.tar.xz 488516 BLAKE2B 96f61ce681d0c259e8df38f35c04349ab3b1199f62c2311d60c6f229bf15e8f62825c965a4847cbda4701119fc7ae3c68cc3a7187f927f8ddf7496cf1931c7c2 SHA512 a695bc4c913a32d47535cb2d8812f14a39732cae32651521a8f7b6d05c4202bfc28a477c88875bbfbe1a0238cd33f1fe64f2d2217b0c27cf11acf7233fc2cbdf
diff --git a/sys-cluster/libqb/libqb-1.0.5.ebuild b/sys-cluster/libqb/libqb-1.0.5.ebuild
new file mode 100644
index 000000000000..1b65743a9677
--- /dev/null
+++ b/sys-cluster/libqb/libqb-1.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/ClusterLabs/libqb"
+SRC_URI="https://github.com/ClusterLabs/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ default
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ use doc && emake doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+
+ use doc && HTML_DOCS=("docs/html/.")
+ einstalldocs
+}