summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/kpathsea/files/kpathsea-6.3.3_p20210325-Fix-Wimplicit-function-declaration.patch23
1 files changed, 21 insertions, 2 deletions
diff --git a/dev-libs/kpathsea/files/kpathsea-6.3.3_p20210325-Fix-Wimplicit-function-declaration.patch b/dev-libs/kpathsea/files/kpathsea-6.3.3_p20210325-Fix-Wimplicit-function-declaration.patch
index ad8dc0e33342..89cf314856ae 100644
--- a/dev-libs/kpathsea/files/kpathsea-6.3.3_p20210325-Fix-Wimplicit-function-declaration.patch
+++ b/dev-libs/kpathsea/files/kpathsea-6.3.3_p20210325-Fix-Wimplicit-function-declaration.patch
@@ -1,5 +1,24 @@
-diff --git a/configure b/configure
-index be42b2e..6a7efb0 100755
+Sent upstream to tlbuild mailing list. Not yet in archive.
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 4 Nov 2022 04:58:38 +0000
+Subject: [PATCH] Fix -Wimplicit-function-declaration
+
+Add <stdlib.h> includes for exit(). Clang 16 makes -Wimplicit-function-declaration an error by default.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,7 +45,8 @@ if test "x$ac_cv_func_getcwd" = xyes; then
+ # We only need to run this if we have getcwd.
+ AC_CACHE_CHECK([whether getcwd uses fork or vfork],
+ [kb_cv_func_getcwd_forks],
+- [AC_RUN_IFELSE([AC_LANG_PROGRAM([[int fork() { exit(1); }
++ [AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h>
++ int fork() { exit(1); }
+ int vfork() { exit(1); }
+ extern char *getcwd();
+ char path[100];]],
--- a/configure
+++ b/configure
@@ -13920,6 +13920,7 @@ else