summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/certbot/certbot-1.26.0.ebuild5
-rw-r--r--app-crypt/certbot/certbot-1.27.0.ebuild5
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/app-crypt/certbot/certbot-1.26.0.ebuild b/app-crypt/certbot/certbot-1.26.0.ebuild
index 2d3795642b7b..44b7e3889a5e 100644
--- a/app-crypt/certbot/certbot-1.26.0.ebuild
+++ b/app-crypt/certbot/certbot-1.26.0.ebuild
@@ -23,6 +23,8 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="selinux"
+
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
@@ -34,6 +36,7 @@ RDEPEND="
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )"
distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-1.27.0.ebuild b/app-crypt/certbot/certbot-1.27.0.ebuild
index 0040de76755a..bad8bc65b32d 100644
--- a/app-crypt/certbot/certbot-1.27.0.ebuild
+++ b/app-crypt/certbot/certbot-1.27.0.ebuild
@@ -23,6 +23,8 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="selinux"
+
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
@@ -34,6 +36,7 @@ RDEPEND="
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )"
distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 0040de76755a..bad8bc65b32d 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -23,6 +23,8 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE="selinux"
+
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
@@ -34,6 +36,7 @@ RDEPEND="
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )"
distutils_enable_tests pytest