summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-3.0.5.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 96b807809a9c..82cce9ec04e6 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,5 +1,4 @@
DIST pytest-2.7.2.tar.gz 532836 SHA256 b30457f735420d0000d10a44bbd478cf03f8bf20e25bd77248f9bab40f4fd6a4 SHA512 5474a4fe58437a4971fb21b1b37dad3c08e18e5d154931ff23e597f881100a3515bf0cf71d06b143465594ad2a91a96f84f4836d84c39691143c8d88ca7a4360 WHIRLPOOL 6ab7371f952109ac476774222883e1381fe5ee6a54d967f2d90765f6c59c90634a16c42e8e2e1661169db6a9cb1327242ff2281cf1caeabd86a4dacd24f4bb06
DIST pytest-3.0.2.tar.gz 727551 SHA256 64d8937626dd2a4bc15ef0edd307d26636a72a3f3f9664c424d78e40efb1e339 SHA512 38485c73f9df3c76b7b920b6957ffe4fbfd32ca0c46b73a53375a40586a482d270bf71b4457b68d48815d50ad173824b269ece255692ae0d1b13f0b1885ce54f WHIRLPOOL b6954a95e5f7d9b904c7543a09c2ef237c76c3a35bcd3e24c402a02aec3b35a19cdb952ac38af4ce43ae516cb5ac52023a0d91f2c587343265edd6d493145e8a
DIST pytest-3.0.3.tar.gz 731934 SHA256 f213500a356800a483e8a146ff971ae14a8df3f2c0ae4145181aad96996abee7 SHA512 ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af WHIRLPOOL 1883909fa23832e674cf912b1d88957dd435143dc124df5454c08ad02c8077473168f749ea94539c2c4b5cf08648a0bce7e90937bbdacd4bb69a4ccf15ecff23
-DIST pytest-3.0.5.tar.gz 740656 SHA256 4a003aa956f023ce91aa6e166b555e6f02a4b0aeb459ac61e14f64c0d39037fd SHA512 b01c6272703ec93b7e7eefa584688a3d00cd97ac9cf54bc9501b596d4c370f9f74e06ee2223829b60469ea1a32c3a3c30b29aeacfaab1f23404d5f8345544ca1 WHIRLPOOL 9b044222fc628dd138e9eaaf27a930b6389e74dff09ec25c07392c4d965c30890a79f5fb663db6de4f612dbabd6338049d2ed45679928835f8c7a278530d6c05
DIST pytest-3.0.6.tar.gz 748748 SHA256 643434a9f1a188271da35e20064cb8b6c5440976c5bb541dc7b5b0e3cf75d940 SHA512 0e983f1f52c18327537d20be30425f4c74037d1fbf6b4aedf2646cf21d450fa9b2b20625f26f5db759b4fe1fd28c6640cb1df88e667efaeea6642e7f02f01e06 WHIRLPOOL 708e5041135883ba31d9712880672f64bf05c0bf40a544061cb42fed4d2aec111bfdf82b63f10e8a87c2b76870e3ea364b396258f0674d2199e43fe93cf2922e
diff --git a/dev-python/pytest/pytest-3.0.5.ebuild b/dev-python/pytest/pytest-3.0.5.ebuild
deleted file mode 100644
index f6688a086761..000000000000
--- a/dev-python/pytest/pytest-3.0.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.29"
-COMMON_DEPEND="
- >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
- doc? (
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
- >dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !dev-python/logilab-common
-"
-
-python_prepare_all() {
- chmod o-w *egg*/* || die
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_nose.py not written to suit py3.2 in pypy3
- if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v \
- --ignore=testing/BUILD_nose.py \
- || die "tests failed with ${EPYTHON}"
- else
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -v testing || die "tests failed with ${EPYTHON}"
- fi
-}
-
-python_compile_all(){
- use doc && emake -C doc/en html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/en/_build/html/. )
- distutils-r1_python_install_all
-}