summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/stdiscosrv/metadata.xml8
-rw-r--r--acct-user/stdiscosrv/stdiscosrv-0.ebuild14
2 files changed, 22 insertions, 0 deletions
diff --git a/acct-user/stdiscosrv/metadata.xml b/acct-user/stdiscosrv/metadata.xml
new file mode 100644
index 000000000000..3e5026ee3754
--- /dev/null
+++ b/acct-user/stdiscosrv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/stdiscosrv/stdiscosrv-0.ebuild b/acct-user/stdiscosrv/stdiscosrv-0.ebuild
new file mode 100644
index 000000000000..06485edd7656
--- /dev/null
+++ b/acct-user/stdiscosrv/stdiscosrv-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the Syncthing discovery server"
+ACCT_USER_ID=497
+ACCT_USER_HOME=/var/lib/stdiscosrv
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( stdiscosrv )
+
+acct-user_add_deps