summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest1
-rw-r--r--app-accessibility/caribou/caribou-0.4.19.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
index 9960825b72a8..e7dfa67c6095 100644
--- a/app-accessibility/caribou/Manifest
+++ b/app-accessibility/caribou/Manifest
@@ -1,3 +1,4 @@
DIST caribou-0.4.17.tar.xz 421960 SHA256 31828886b812421dd7217a7aa29043945b8601f3a101507f7e3faa0dc157e516 SHA512 97e773fb44f6bcf827bd8c839cd0669e029ebb377e1c3c777f7acf1cbf262ee58af09ea3e941843bc9519eee3bb59f3c572c04ddea0fb888baac9129c74c8932 WHIRLPOOL b3dee923e7815788655279857c5f6b4a6eac9ad34cffffff0b95f05bcb36ea09882acea5b88e1043b2c806d7a78a52a86772affd2e052588eacec41e76fcbf6b
DIST caribou-0.4.18.1.tar.xz 410548 SHA256 aefadf125a647fc68696f4134e99ee43dca121da5de8e1edf6eab5664a9f3150 SHA512 226ca64fafb4e7c5e38ba714059e9e6ef7bbfce04160b98884fb299dc465e4f7d278033477f2539ba64fe9c39c62448903a8273dee0315bff81dbbe107d665d5 WHIRLPOOL 1310f79944ee547535a04563dd7910dfff2db400faf6c28685deecc062432759a24f0587f875d88cc87ddcdcd4c249a83abde0222ffcab4a24afe91dc9a55cdb
DIST caribou-0.4.18.tar.xz 422580 SHA256 8d94977f3364926600b5f711406e765a9a61aa444609f87a1d435b301e147226 SHA512 cb1dbfa33ef7898b98d05af8ec937f4ecd6ee17148d136186e6bd1e00da97c4146d04e283f9b72a2ac88e8379f8aa4051535a247bce91dd87f32558322fa3720 WHIRLPOOL 5e3dcfb5ccf74d33f698678092468b2236b7cb1e78ba53816221c1c159c1a657ad32f56f2f389075d1ab4fb363ddaf019f0f3d27164b061ae8e9bba47015a56c
+DIST caribou-0.4.19.tar.xz 412328 SHA256 2f0bd0c14c5f94cf5ac3a7627018919addf7a054ac84aaa8e62356957c175a44 SHA512 ae8fd278612778eae35810eee199dc9c64b45340de1459cc71eb5806ebc14ddd05e7e0e5464e2976d0160a50c6d76656a7ed0362bfd79eecdc09de1fc78b6de1 WHIRLPOOL db26dbc91e231558712bd33f57f857de660cc17f5c7c6c8c8fd2687807b75d5784df8654e0328c35a4e06902ec5a628609b8c9dd2d568a2afcb59c2f12c081a8
diff --git a/app-accessibility/caribou/caribou-0.4.19.ebuild b/app-accessibility/caribou/caribou-0.4.19.ebuild
new file mode 100644
index 000000000000..26c3157d1a76
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.19.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+ sed -e '/export PYTHONPATH=.*python/ d' \
+ -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+ -i bin/{antler-keyboard,caribou-preferences}.in ||
+ die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}