summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch')
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
new file mode 100644
index 000000000000..61c991c8a368
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile 2017-06-13 11:08:23.428114301 -0500
++++ b/Makefile 2017-06-13 11:09:01.084376256 -0500
+@@ -28,10 +28,10 @@
+ djgppall: nfbtrans.exe
+
+ nfbtrans: $(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ nfbtrans.exe:$(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) -o nfbtrans.exe
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) -o nfbtrans.exe
+
+ ultrix:
+ $(MAKE) CFLAGS=-O
+@@ -44,7 +44,7 @@
+
+ insight:
+ insight -fno-builtin -fwritable-strings \
+- $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ aix:
+ $(MAKE) all CC=cc CFLAGS="-o -Dunix -Daix"