summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-1.9.4.ebuild')
-rw-r--r--app-admin/ansible/ansible-1.9.4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-admin/ansible/ansible-1.9.4.ebuild b/app-admin/ansible/ansible-1.9.4.ebuild
deleted file mode 100644
index a08091ba13b4..000000000000
--- a/app-admin/ansible/ansible-1.9.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils readme.gentoo
-
-DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
-HOMEPAGE="http://ansible.com/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="test"
-
-RDEPEND="
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/keyczar[${PYTHON_USEDEP}]
- >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-# not included in release tarball
-RESTRICT="test"
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- EXAMPLES=( examples )
- distutils-r1_python_install_all
-
- doman docs/man/man1/*.1
-
- newenvd "${FILESDIR}"/${PN}.env 95ansible
-}
-
-src_install() {
- distutils-r1_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- optfeature "Alternative ssh transport" dev-python/paramiko
-}