summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-2.9.9.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.9.9.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-admin/ansible/ansible-2.9.9.ebuild b/app-admin/ansible/ansible-2.9.9.ebuild
deleted file mode 100644
index 8c8b3a948043..000000000000
--- a/app-admin/ansible/ansible-2.9.9.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}