summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/bastille')
-rw-r--r--app-admin/bastille/bastille-3.0.9-r1.ebuild18
-rw-r--r--app-admin/bastille/bastille-3.0.9-r2.ebuild13
2 files changed, 14 insertions, 17 deletions
diff --git a/app-admin/bastille/bastille-3.0.9-r1.ebuild b/app-admin/bastille/bastille-3.0.9-r1.ebuild
index 1088834fccd1..19860743e3f6 100644
--- a/app-admin/bastille/bastille-3.0.9-r1.ebuild
+++ b/app-admin/bastille/bastille-3.0.9-r1.ebuild
@@ -11,22 +11,22 @@ MY_PN=${PN/b/B}
MY_P=${MY_PN}-${PV}
S=${WORKDIR}/${MY_PN}
DESCRIPTION="Bastille-Linux is a security hardening tool"
-HOMEPAGE="http://bastille-linux.org/"
+HOMEPAGE="http://bastille-linux.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="X"
RDEPEND="
- net-firewall/iptables
app-admin/logrotate
dev-perl/Curses
+ net-firewall/iptables
net-firewall/psad
- X? ( dev-perl/Tk )
virtual/logger
+ X? ( dev-perl/Tk )
"
src_prepare() {
@@ -36,7 +36,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-perl.patch"
perl_set_version
- cd "${S}"
+ cd "${S}" || die
chmod a+x Install.sh bastille-ipchains bastille-netfilter
}
@@ -44,20 +44,20 @@ src_install() {
perl_set_version
export VENDOR_LIB
- cd "${S}"
+ cd "${S}" || die
DESTDIR="${D}" ./Install.sh
# Example configs
- cd "${S}"
+ cd "${S}" || die
insinto /usr/share/Bastille
doins *.config
newinitd ${PN}-firewall.gentoo-init ${PN}-firewall
# Documentation
- cd "${S}"
+ cd "${S}" || die
dodoc *.txt BUGS Change* README*
- cd "${S}"/docs
+ cd "${S}"/docs || die
doman *.1m
}
diff --git a/app-admin/bastille/bastille-3.0.9-r2.ebuild b/app-admin/bastille/bastille-3.0.9-r2.ebuild
index 01d5a028636d..ae6415282920 100644
--- a/app-admin/bastille/bastille-3.0.9-r2.ebuild
+++ b/app-admin/bastille/bastille-3.0.9-r2.ebuild
@@ -3,41 +3,38 @@
EAPI=6
-inherit eutils perl-functions
+inherit perl-functions
PATCHVER=0.2
MY_PN=${PN/b/B}
MY_P=${MY_PN}-${PV}
S=${WORKDIR}/${MY_PN}
DESCRIPTION="Bastille-Linux is a security hardening tool"
-HOMEPAGE="http://bastille-linux.org/"
+HOMEPAGE="http://bastille-linux.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="X"
RDEPEND="
- net-firewall/iptables
app-admin/logrotate
dev-lang/perl:=
dev-perl/Curses
+ net-firewall/iptables
net-firewall/psad
- X? ( dev-perl/Tk )
virtual/logger
+ X? ( dev-perl/Tk )
"
PATCHES=(
"${WORKDIR}"/${P}-gentoo-${PATCHVER}.patch
-
# make sure the Perl modules go into vendor dir
"${FILESDIR}/${P}-perl.patch"
-
# prevent file collision, bug 536292
"${FILESDIR}/${P}-renamewidgets.patch"
-
# openrc runscript rename
"${FILESDIR}/${P}-openrc.patch"
)