summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clog/clog-1.3.0-r1.ebuild')
-rw-r--r--app-admin/clog/clog-1.3.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/clog/clog-1.3.0-r1.ebuild b/app-admin/clog/clog-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..cc6689579c1b
--- /dev/null
+++ b/app-admin/clog/clog-1.3.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="clog is a colorized log tail utility"
+HOMEPAGE="https://taskwarrior.org/docs/clog/"
+SRC_URI="https://gothenburgbitfactory.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+RESTRICT="test" # No test suite on tar.gz
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.0-gcc13.patch
+)
+
+src_prepare() {
+ sed -i -e 's|share/doc/clog|share/clog|' CMakeLists.txt || die
+ cmake_src_prepare
+}