summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clsync/clsync-9999.ebuild')
-rw-r--r--app-admin/clsync/clsync-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-admin/clsync/clsync-9999.ebuild b/app-admin/clsync/clsync-9999.ebuild
index 05e00ff84f2b..f97b3e7c2752 100644
--- a/app-admin/clsync/clsync-9999.ebuild
+++ b/app-admin/clsync/clsync-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,9 +6,8 @@ EAPI=7
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/clsync/clsync.git"
inherit git-r3
- KEYWORDS=""
else
- SRC_URI="https://github.com/clsync/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ SRC_URI="https://github.com/clsync/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -30,7 +29,7 @@ REQUIRED_USE="
"
BDEPEND="
virtual/pkgconfig
- apidoc? ( app-doc/doxygen[dot] )
+ apidoc? ( app-text/doxygen[dot] )
"
DEPEND="
caps? ( sys-libs/libcap )
@@ -66,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \