summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cronlocker/cronlocker-0.5.0.ebuild')
-rw-r--r--app-admin/cronlocker/cronlocker-0.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-admin/cronlocker/cronlocker-0.5.0.ebuild b/app-admin/cronlocker/cronlocker-0.5.0.ebuild
new file mode 100644
index 000000000000..b92604a122f4
--- /dev/null
+++ b/app-admin/cronlocker/cronlocker-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="synchronize a cron job across multiple hosts using the consul lock feature"
+HOMEPAGE="https://github.com/viafintech/cronlocker"
+SRC_URI="https://github.com/Barzahlen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ go build -o cronlocker . || die
+}
+
+src_install() {
+ dobin cronlocker
+ dodoc *.md package/changelog
+}