summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/doctl/doctl-9999.ebuild')
-rw-r--r--app-admin/doctl/doctl-9999.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-admin/doctl/doctl-9999.ebuild b/app-admin/doctl/doctl-9999.ebuild
index 654c28a745f8..9837f24928f9 100644
--- a/app-admin/doctl/doctl-9999.ebuild
+++ b/app-admin/doctl/doctl-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"
-inherit bash-completion-r1 git-r3 go-module
+inherit bash-completion-r1 edo git-r3 go-module
DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
@@ -14,7 +14,6 @@ SRC_URI=""
LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
src_unpack() {
git-r3_src_unpack
@@ -23,17 +22,17 @@ src_unpack() {
src_compile() {
LDFLAGS="-X github.com/digitalocean/doctl.Build=$(git rev-parse --short HEAD)
-X github.com/digitalocean/doctl.Label=dev"
- GOFLAGS="-v -x -mod=vendor" \
- go build -ldflags "$LDFLAGS" ./cmd/... || die "build failed"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
- ./doctl completion bash > doctl.bash || die "completion for bash failed"
- ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
- ./doctl completion fish > doctl.fish || die "completion for fish failed"
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
}
src_test() {
- GOFLAGS="-v -x -mod=vendor" \
- go test -work ./do/... ./pkg/... . || die "test failed"
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
}
src_install() {