summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/doctl')
-rw-r--r--app-admin/doctl/Manifest2
-rw-r--r--app-admin/doctl/doctl-1.55.0.ebuild40
-rw-r--r--app-admin/doctl/doctl-1.56.0.ebuild44
3 files changed, 0 insertions, 86 deletions
diff --git a/app-admin/doctl/Manifest b/app-admin/doctl/Manifest
index b53f3e75f530..1dc7041d6b22 100644
--- a/app-admin/doctl/Manifest
+++ b/app-admin/doctl/Manifest
@@ -1,3 +1 @@
-DIST doctl-1.55.0.tar.gz 5157504 BLAKE2B 1d3db2ee4ca71a459456e72f035648c5ba73c5372c3369b360e1ee3cc44ec1155295e5f425611c307371f902c7ffed7dbce2f959266f79ecb8f149144fc86596 SHA512 6cea86e184ea25d5a6740d4090148fbe053ce93ebe8f2344f5a2bf62283381ed2a9574862a5ba39f34a52bf85af550313b7dd316a321f31089673f898d37cf78
-DIST doctl-1.56.0.tar.gz 5163349 BLAKE2B 10f169f7ccf31b416509043f42bff3fd60a5618530217b46d2bd0797d70eba914d314b376b5fdd801ba12ee4746e17b4e7a33316d9adcb95403ac3a92152d86e SHA512 4102f58ea0925b110d4ddf2146cdec0a4252881b7724c34c4ef0c86f848b107380d6b425e11a885841d39f52d6cb00bfab5671d663efcfe5ba02dcae8b5975c9
DIST doctl-1.57.0.tar.gz 5195498 BLAKE2B 17273e9f8f63464aa2ba6c6d48dfabd78b0bdeb7156dc315d1970fb0052710c7a4b37f1d5e2a7a60211f2ab166c0926de438959d853639a8c329ec39b3ee0577 SHA512 0c868c5732a48367a93bf2b884689dbd917ba6690c82516495862546bc31d58d44aab192bd3b3543f951e9fa9b7289e99fbdf828c017af68496b84f1585a5f6b
diff --git a/app-admin/doctl/doctl-1.55.0.ebuild b/app-admin/doctl/doctl-1.55.0.ebuild
deleted file mode 100644
index 8241168248ab..000000000000
--- a/app-admin/doctl/doctl-1.55.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="A command line tool for DigitalOcean services"
-HOMEPAGE="https://github.com/digitalocean/doctl"
-SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_compile() {
- GOFLAGS="-v -x -mod=vendor" \
- go build ./cmd/... || die "build failed"
-
- ./doctl completion bash > doctl.bash || die "completion for bash failed"
- ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
- ./doctl completion fish > doctl.fish || die "completion for fish failed"
-}
-
-src_test() {
- GOFLAGS="-v -x -mod=vendor" \
- go test -work ./do/... ./pkg/... . || die "test failed"
-}
-
-src_install() {
- einstalldocs
- dobin doctl
-
- newbashcomp doctl.bash doctl
- insinto /usr/share/zsh/site-functions
- newins doctl.zsh _doctl
- insinto /usr/share/fish/completion
- newins doctl.fish doctl
-}
diff --git a/app-admin/doctl/doctl-1.56.0.ebuild b/app-admin/doctl/doctl-1.56.0.ebuild
deleted file mode 100644
index c1ed045f556d..000000000000
--- a/app-admin/doctl/doctl-1.56.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="A command line tool for DigitalOcean services"
-HOMEPAGE="https://github.com/digitalocean/doctl"
-SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_compile() {
- LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
- -X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
- -X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
- -X github.com/digitalocean/doctl.Label=release"
- GOFLAGS="-v -x -mod=vendor" \
- go build -ldflags "$LDFLAGS" ./cmd/... || die "build failed"
-
- ./doctl completion bash > doctl.bash || die "completion for bash failed"
- ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
- ./doctl completion fish > doctl.fish || die "completion for fish failed"
-}
-
-src_test() {
- GOFLAGS="-v -x -mod=vendor" \
- go test -work ./do/... ./pkg/... . || die "test failed"
-}
-
-src_install() {
- einstalldocs
- dobin doctl
-
- newbashcomp doctl.bash doctl
- insinto /usr/share/zsh/site-functions
- newins doctl.zsh _doctl
- insinto /usr/share/fish/completion
- newins doctl.fish doctl
-}