summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/evtxtools/evtxtools-1.1.1-r2.ebuild')
-rw-r--r--app-admin/evtxtools/evtxtools-1.1.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/evtxtools/evtxtools-1.1.1-r2.ebuild b/app-admin/evtxtools/evtxtools-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..9b0c4c29cd6b
--- /dev/null
+++ b/app-admin/evtxtools/evtxtools-1.1.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+MY_PN="Parse-Evtx"
+DESCRIPTION="Read, decode and dump Windows Vista/2008/7 event log file"
+HOMEPAGE="http://computer.forensikblog.de/en/topics/windows/vista_event_log"
+SRC_URI="http://computer.forensikblog.de/files/evtx/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-perl/Digest-CRC
+ dev-perl/DateTime
+ dev-perl/Carp-Assert
+ dev-perl/Data-Hexify
+"
+
+BDEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_postinst() {
+ einfo "Consider the following as how-to:"
+ einfo "http://rwmj.wordpress.com/2011/04/17/decoding-the-windows-event-log-using-guestfish/"
+}