summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/go-updater')
-rw-r--r--app-admin/go-updater/Manifest1
-rw-r--r--app-admin/go-updater/go-updater-0.1.0.ebuild24
-rw-r--r--app-admin/go-updater/metadata.xml11
3 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/go-updater/Manifest b/app-admin/go-updater/Manifest
new file mode 100644
index 000000000000..059e45bf446c
--- /dev/null
+++ b/app-admin/go-updater/Manifest
@@ -0,0 +1 @@
+DIST go-updater-0.1.0.tar.gz 1754 BLAKE2B 720a328e8f28d2f0b28400053776ff8dbe52e24be7b20812d01b148bde72eda948acb5867b8ca16af7b40d20e36d36d3ffbd846c4992bb1dbe2af6db0069e765 SHA512 321f7faaec62b653c2b01f6f2e2c0104b536e63dfeb6aacd72c493d3fdc7b3bc5b96d6eff02ec1603adde1879dacbd51f4ced37c3cd94361120cc482432cb8a5
diff --git a/app-admin/go-updater/go-updater-0.1.0.ebuild b/app-admin/go-updater/go-updater-0.1.0.ebuild
new file mode 100644
index 000000000000..78dc6698a598
--- /dev/null
+++ b/app-admin/go-updater/go-updater-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Checks if Gentoo go packages are compiled with the system's golang version"
+HOMEPAGE="https://github.com/mrueg/go-updater"
+SRC_URI="https://github.com/mrueg/go-updater/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-go/goversion"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}
diff --git a/app-admin/go-updater/metadata.xml b/app-admin/go-updater/metadata.xml
new file mode 100644
index 000000000000..f2eeaac7c70e
--- /dev/null
+++ b/app-admin/go-updater/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mrueg/go-updater</remote-id>
+ </upstream>
+</pkgmetadata>