summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassx/keepassx-0.4.3.ebuild')
-rw-r--r--app-admin/keepassx/keepassx-0.4.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-0.4.3.ebuild b/app-admin/keepassx/keepassx-0.4.3.ebuild
new file mode 100644
index 000000000000..333f4851a6a6
--- /dev/null
+++ b/app-admin/keepassx/keepassx-0.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug pch"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4
+ || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+
+src_configure() {
+ local conf_pch
+ use pch && conf_pch="PRECOMPILED=1" || conf_pch="PRECOMPILED=0"
+
+ eqmake4 ${PN}.pro -recursive \
+ PREFIX="${ED}/usr" \
+ "${conf_pch}"
+}
+
+src_compile() {
+ # workaround compile failure due to distcc, bug #214327
+ PATH=${PATH/\/usr\/lib\/distcc\/bin:}
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc changelog
+}