summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lnav/lnav-0.8.4.ebuild')
-rw-r--r--app-admin/lnav/lnav-0.8.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/lnav/lnav-0.8.4.ebuild b/app-admin/lnav/lnav-0.8.4.ebuild
new file mode 100644
index 000000000000..0d788cfb2991
--- /dev/null
+++ b/app-admin/lnav/lnav-0.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs autotools
+
+DESCRIPTION="A curses-based tool for viewing and analyzing log files"
+HOMEPAGE="http://lnav.org"
+SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-db/sqlite:3
+ dev-libs/libpcre[cxx]
+ >=net-misc/curl-7.23.0
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+PATCHES=( "${FILESDIR}"/${P}-disable-tests.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with unicode ncursesw)
+}