summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pass/pass-9999.ebuild')
-rw-r--r--app-admin/pass/pass-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index a6ee842f8175..0fd8dcb77e6b 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,27 +10,25 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
S="${WORKDIR}/password-store-${PV}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
fi
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
-SLOT="0"
LICENSE="GPL-2"
-IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+SLOT="0"
+IUSE="+git wayland X emacs dmenu importers"
RDEPEND="
app-crypt/gnupg
- media-gfx/qrencode
+ media-gfx/qrencode[png(+)]
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
- zsh-completion? ( app-shells/gentoo-zsh-completions )
- fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
@@ -57,13 +55,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
- WITH_ZSHCOMP=$(usex zsh-completion) \
- WITH_FISHCOMP=$(usex fish-completion)
+ WITH_ZSHCOMP=yes \
+ WITH_FISHCOMP=yes
+
use dmenu && dobin contrib/dmenu/passmenu
+
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
+
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*