summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sysklogd/sysklogd-9999.ebuild')
-rw-r--r--app-admin/sysklogd/sysklogd-9999.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/app-admin/sysklogd/sysklogd-9999.ebuild b/app-admin/sysklogd/sysklogd-9999.ebuild
index ff5b1d0d7b53..24bef0bd0a53 100644
--- a/app-admin/sysklogd/sysklogd-9999.ebuild
+++ b/app-admin/sysklogd/sysklogd-9999.ebuild
@@ -1,53 +1,54 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic systemd toolchain-funcs
DESCRIPTION="Standard log daemons"
HOMEPAGE="https://troglobit.com/sysklogd.html https://github.com/troglobit/sysklogd"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/troglobit/sysklogd.git"
else
SRC_URI="https://github.com/troglobit/sysklogd/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="BSD"
SLOT="0"
-IUSE="logger logrotate systemd"
+IUSE="logger logrotate"
+# Needs network access
RESTRICT="test"
DEPEND="
- logger? (
- !<sys-apps/util-linux-2.34-r3
- !>=sys-apps/util-linux-2.34-r3[logger]
- )
+ logger? ( sys-apps/util-linux[-logger(+)] )
+"
+RDEPEND="
+ ${DEPEND}
+ logrotate? ( app-admin/logrotate )
"
-RDEPEND="${DEPEND}"
DOCS=( ChangeLog.md README.md )
-pkg_setup() {
- append-lfs-flags
- tc-export CC
-}
-
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
+ append-lfs-flags
+ tc-export CC
+
local myeconfargs=(
--disable-static
--runstatedir="${EPREFIX}"/run
+ --with-systemd=$(systemd_get_systemunitdir)
$(use_with logger)
- $(use_with systemd systemd $(systemd_get_systemunitdir))
)
+
econf "${myeconfargs[@]}"
}
@@ -76,6 +77,7 @@ pkg_postinst() {
elog "functionality that does no longer require a running cron daemon."
elog "So we no longer install any log rotation cron files for sysklogd."
fi
+
if [[ -n ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 2.1 ; then
elog "Starting with version 2.1 sysklogd no longer provides klogd."
elog "syslogd now also logs kernel messages."