summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tripwire/tripwire-2.4.3.7.ebuild')
-rw-r--r--app-admin/tripwire/tripwire-2.4.3.7.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/app-admin/tripwire/tripwire-2.4.3.7.ebuild b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
index 41ea0cc71d54..b89e3608164d 100644
--- a/app-admin/tripwire/tripwire-2.4.3.7.ebuild
+++ b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="Open Source File Integrity Checker and IDS"
HOMEPAGE="http://www.tripwire.org/"
@@ -12,13 +12,10 @@ SRC_URI="https://github.com/Tripwire/tripwire-open-source/archive/${PV}.tar.gz -
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="libressl selinux ssl static +tools"
+IUSE="selinux ssl static +tools"
DEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ ssl? ( dev-libs/openssl:0= )
"
RDEPEND="${DEPEND}
virtual/cron
@@ -39,8 +36,17 @@ src_configure() {
# see #32613, #45823, and others.
# -taviso@gentoo.org
strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- econf $(use_enable ssl openssl) $(use_enable static)
+
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""'
+ append-flags -fno-strict-aliasing
+
+ # "integer.cpp:1162:24: error: reference to ‘byte’ is ambiguous"
+ # bug #786465
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable static)
}
src_install() {
@@ -71,7 +77,7 @@ pkg_postinst() {
elog "script provided by the app-admin/mktwpol package. This package is"
elog "installed for you by the \"tools\" USE flag (which is enabled by"
elog "default."
-else
+ else
elog "Maintenance of tripwire policy files as packages are added"
elog "and deleted from your system can be automated by the mktwpol.sh"
elog "script provided by the app-admin/mktwpol package. This package"