summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/usbview/usbview-3.0.ebuild')
-rw-r--r--app-admin/usbview/usbview-3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/usbview/usbview-3.0.ebuild b/app-admin/usbview/usbview-3.0.ebuild
new file mode 100644
index 000000000000..c1a37d825fc9
--- /dev/null
+++ b/app-admin/usbview/usbview-3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~DEBUG_FS"
+ linux-info_pkg_setup
+}