summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config/webapp-config-1.55-r1.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.55-r1.ebuild b/app-admin/webapp-config/webapp-config-1.55-r1.ebuild
deleted file mode 100644
index f8cb336a9af6..000000000000
--- a/app-admin/webapp-config/webapp-config-1.55-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-inherit distutils-r1 prefix
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- sys-apps/gentoo-functions"
-RDEPEND="
- portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- eprefixify WebappConfig/eprefix.py config/webapp-config
-}
-
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "Now that you have upgraded webapp-config, you **must** update your"
- elog "config files in /etc/vhosts/webapp-config before you emerge any"
- elog "packages that use webapp-config."
-}