summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/selint/Manifest1
-rw-r--r--app-admin/selint/selint-1.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/selint/Manifest b/app-admin/selint/Manifest
index efeb4bfb72ef..1bca72c5998f 100644
--- a/app-admin/selint/Manifest
+++ b/app-admin/selint/Manifest
@@ -1 +1,2 @@
DIST selint-1.1.0.tar.gz 283926 BLAKE2B 0908f8830ce4b569c54e8c025dd92c39af59172fee0b8061f5b8cdaf61222979a78c3726a5647af9161ce7e4a7ddd5bee64772afecd2024368afa76294b3d317 SHA512 3af358e0f42a285a0360ce2b4db9014ef1e4f0b792623007f88cf510799080975d9e44817e8911bbd32b141704a7fd11e1b4d8f91e124d0fa91c38f71a978c91
+DIST selint-1.2.0.tar.gz 306527 BLAKE2B 842d796d3beea327ac937b977123a9248f317f0ab88e8187ff5ef7b7da2efd9b6c4bccda2dc1fd4661691904f90f346df0120f9398733e62942e70bef5c3c5ab SHA512 e289cb0a25454b1fd5f5435e11f3d956e6c545bbbbe79b7a47d40681746d8eb66bb78bdb541f2629a4f23435853568a8e52d10e6f8dde8e8ddb03f4493ea7504
diff --git a/app-admin/selint/selint-1.2.0.ebuild b/app-admin/selint/selint-1.2.0.ebuild
new file mode 100644
index 000000000000..a0e18d3a3fef
--- /dev/null
+++ b/app-admin/selint/selint-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Static code analysis of refpolicy style SELinux policy"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}