summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.0.19.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index a89be67912fc..db48d55649c3 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -2,5 +2,6 @@ DIST mongo-tools-3.6.13.tar.gz 4990848 BLAKE2B 022ddf214869c3a3e545aa9572f77f0ad
DIST mongo-tools-3.6.17.tar.gz 4991196 BLAKE2B 53e86b3513aa74ad174801cea987d574c5248f438cb0a9419c2352c04333eae2f92214b11c59ee8688ad7235dc7a4586c39cc27450c654b1fc0e2eec2e4e22e2 SHA512 ea7a010097fdfe7807daf9352519b808b4a7b614b793ee2ac27495207bcf1cf8b4151fecd525946a0d6b8aa9332c205f437d5141b16efb613810963f502061be
DIST mongo-tools-4.0.12.tar.gz 11134652 BLAKE2B d3c9703046dc577b85cefe1185678e0029411ddd44d0648f9b09fc3ab41e3661891d18afd83bf1a148dc4c9208895f444c115948e515e09dfa3062e89d98fc24 SHA512 068d8c456386caddcce23fa8917ffecdc9b5c39fb6794c5cd1d9099be1f127ecf680b006055581dc3d90507072a87788b46be7410f0dbede42da64c664b77ced
DIST mongo-tools-4.0.16.tar.gz 11139827 BLAKE2B 550acfd7e4434b178170dfd94c65668cb7dd37d128235c63a10f72802e3119f33d5cd2138bfd5b957f6d3813f1d9aff49218c4e122c0cd454b4ea7a969c84d4e SHA512 a75831d9fd0b596bfb7354cbc05d1ecf6871d5a7230a858b09b94d5001d18069c9cbe89c9500e9c1a16fc5186fa7a1ac59c605156666a3f1a2d7c81115a47c16
+DIST mongo-tools-4.0.19.tar.gz 11139649 BLAKE2B 7e730138fce671e18a0ebe929b98eff1c0ce2c364ceef7d6868c380242689411c545ac321aebd609dcfe9f8d5b7d35cf37973a978f35a50cc44902b2dbad7134 SHA512 2639cb27a5a27e405bddf9817f409af244d643a9091f7e5ddff4876966af55b6710b0fe158c351df9aea10f3da0b87d224bfb2c962f4ca2cfe41f804cb16749c
DIST mongo-tools-4.2.3.tar.gz 15020325 BLAKE2B 8501a3ec6e947112ec561ce62f2ea568984f8ac911a7aff3cb8c08c1f29d2cfc64cf7f4b6a24ba73ae0f9b2b5853480f4fbed51c98fdc8c83cd433ea65e21dba SHA512 772719b450f8b656c22ac0126fee1e0fa58b5320c94ac6414b1d9af13e6437393c2482f2e386f4a73c84a2d1bfe0ea88df117a6a7ae87f4884477505cf662585
DIST mongo-tools-4.2.6.tar.gz 15016596 BLAKE2B 5ee37bf21ea05ec5ba2764c935c1dd3632753e772a01f854dc8a9949620e9a41fe95ba658a0efae0332ed2c059561e39e681f672cf5f4302a7f92c364cfab4b6 SHA512 e91bfba4b015f80d35b6c2ca766c599c5eedea113d6415ec0aef433d46b5e5fe06956481a063e26908a45fdcee4002125ea01a29fa3ea9a541a9210d25625f8e
diff --git a/app-admin/mongo-tools/mongo-tools-4.0.19.ebuild b/app-admin/mongo-tools/mongo-tools-4.0.19.ebuild
new file mode 100644
index 000000000000..86f626904b91
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.0.19.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # allow building with go 1.12 #678924
+ sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}