summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/Manifest1
-rw-r--r--app-admin/testdisk/testdisk-7.1_pre20180922.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index 2a977ec6d5e6..99dba768e846 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1 +1,2 @@
+DIST testdisk-6837474129968d7de13d91e5454bd824c9136e73.tar.gz 637265 BLAKE2B 7d7a2c875db9d34ad5be687ef0ccc8122759c645b30faf6eed7967747e69ac988078ab6c1909007c32c6bf5a879a5bfd00dff3d2d268e5b50e3b60a8b660c636 SHA512 b494e23ccd8f913a9b22f4b803b02af66e94f6971f45e6aea8a0e1dd8549996e7bdd3fafcf70078ebc242f262d064cdc5674d99cb7a367b810c45c0b1c40336d
DIST testdisk-7.1_pre20180322.tar.gz 632598 BLAKE2B 741610622c9afa2c41d14e8eb391cbe629a5f7ac102cf4cbf446b0c0d7330cb8482a17c1ce8470aa9d1b0578aac254cf17aa061e21dd831a803152514fab5422 SHA512 fbe699ccfbe31be636d71eda5d1fccb8efb16788bf664e048ee16344c3d3689961aaa7ef4c9123690db695bb7ae3439440bd775ab8b8455500232b2fc6048ebc
diff --git a/app-admin/testdisk/testdisk-7.1_pre20180922.ebuild b/app-admin/testdisk/testdisk-7.1_pre20180922.ebuild
new file mode 100644
index 000000000000..f5f2f95d5e0a
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.1_pre20180922.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_COMMIT=6837474129968d7de13d91e5454bd824c9136e73
+inherit autotools flag-o-matic gnome2-utils
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://git.cgsecurity.org/cgit/${PN}/snapshot/${PN}-${EGIT_COMMIT}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="ewf jpeg ntfs qt5 reiserfs static zlib"
+
+REQUIRED_USE="static? ( !qt5 )"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+COMMON_DEPEND="
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( virtual/jpeg:0[static-libs] )
+ ntfs? ( sys-fs/ntfs3g:=[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf:=[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( virtual/jpeg:0 )
+ ntfs? ( sys-fs/ntfs3g )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="!static? ( ${COMMON_DEPEND} )"
+
+DOCS=( )
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-sudo
+ --without-ntfs
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs ntfs3g)
+ $(use_enable qt5 qt)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myeconfargs[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}