summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.6.8.ebuild66
-rw-r--r--app-admin/ansible/ansible-2.7.2.ebuild66
3 files changed, 134 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 98eebc16c2c6..a406c928daf9 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,5 @@
DIST ansible-2.5.11.tar.gz 10114022 BLAKE2B 196c657c66b588ed709b8354d7f043c12701f08e263ede1224f59457b7d65c113d6a936150c0379378615e7a89a66db6a8cfc52304f2c3431a4cafbed9a3bdb5 SHA512 b0da66fb67bdd33b42b35239d392793cc19b98650990028ef89b83384285ab6185accbfe15edb030b9e9a62e59961a22e2002b6aeea34f1f063da857ad199358
DIST ansible-2.6.7.tar.gz 10708387 BLAKE2B cfdd8940e3c23183fa8650d9c5a46b9af056dc9850b25b7969925ea66f2ec7d78945efaf982bc8c8752a285295461922b3e047b4edf75ecf3e3d4c893f0dafbc SHA512 23fde88f7e2151154cd77bb8a946c06c703b620456e0f1e9dc74f532b95d2868eb96e9c6f52fc48fc75ed5ad77d45d61be48fe4b7bd11ac8baa4745a026852bc
+DIST ansible-2.6.8.tar.gz 10714750 BLAKE2B 303e1be319d7fbe3ef6cccace6bcaafef8ddacc0ea2d749cabe71dbeae1bb8ca6bb770e45f226425625e6d045e31cff7f0ef08feafbebbd1db5751f11699a26e SHA512 a072ad1dac730dc9be50c902acd8ae6ba03cb82eecb505ed70e9cb33957fc0391c0461b89593331731e10dad970ee8f81843b1e1039788c320f593db1241ecf4
DIST ansible-2.7.1.tar.gz 11738557 BLAKE2B 8d154d9f09eabd851fb182cea3a6a810385ed971429f4968b649ccd7e5cbbb5c6cd884a478b235f04f12134b471c99a4f77c32826661cc73cbb9e3a1159c377c SHA512 263ebc5fb172c7eda0cc703508ba06a5a6ab197923597a616bcdf28b8bc673ff6117c72cbff4546a1f3628656b0c4d7dd05c34c75e68b9a0d9c29ea9b5a4162f
+DIST ansible-2.7.2.tar.gz 11755722 BLAKE2B 8f1b733f2d4569bd6d1fd52b49b984104bccca28e5fc572abea56572b634a5acfd556562f6a2d2d32277282c8ca7f0c35f2e768d2935dc7d161b2389b37b62e2 SHA512 ee1dcacfdf6af8124b3b000acecb7dcfbf4f221eefbd3165c109e03c8ce7efee56ad643f143a1d159c1ac539536490a15547a9d0635b3c7daae2c9cbda7bc824
diff --git a/app-admin/ansible/ansible-2.6.8.ebuild b/app-admin/ansible/ansible-2.6.8.ebuild
new file mode 100644
index 000000000000..71d5cc29eccb
--- /dev/null
+++ b/app-admin/ansible/ansible-2.6.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}
diff --git a/app-admin/ansible/ansible-2.7.2.ebuild b/app-admin/ansible/ansible-2.7.2.ebuild
new file mode 100644
index 000000000000..2f38c77741e1
--- /dev/null
+++ b/app-admin/ansible/ansible-2.7.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}