summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bzip2/bzip2-9999.ebuild')
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild40
1 files changed, 20 insertions, 20 deletions
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
index a0c9cd7a462f..e8b4774ac56e 100644
--- a/app-arch/bzip2/bzip2-9999.ebuild
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -1,24 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson multilib-minimal usr-ldscript
+inherit meson-multilib usr-ldscript
DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="https://gitlab.com/federicomenaquintero/bzip2"
-if [[ "${PV}" == 9999 ]] ; then
+HOMEPAGE="https://gitlab.com/bzip2/bzip2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.com/bzip2/bzip2"
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
else
- SRC_URI=""
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos"
fi
+
LICENSE="BZIP2"
SLOT="0/1" # subslot = SONAME
IUSE="static-libs"
+PDEPEND="
+ app-alternatives/bzip2
+"
+
multilib_src_configure() {
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
@@ -29,25 +33,22 @@ multilib_src_configure() {
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
multilib_src_install() {
meson_src_install
if multilib_is_native_abi ; then
gen_usr_ldscript -a bz2
-
- dodir /bin
- mv "${ED}"/usr/bin/bzip2 "${ED}"/bin || die
fi
}
multilib_src_install_all() {
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
+ dodir /bin
+ mv "${ED}"/usr/bin/bzip2 "${ED}"/bin/bzip2-reference || die
+ mv "${ED}"/usr/share/man/man1/bzip2{,-reference}.1 || die
+
+ # moved to app-alternatives/bzip2
+ rm "${ED}"/usr/bin/{bzcat,bunzip2} || die
+ rm "${ED}"/usr/share/man/man1/{bzcat,bunzip2.1} || die
dosym bzdiff /usr/bin/bzcmp
dosym bzmore /usr/bin/bzless
@@ -56,8 +57,7 @@ multilib_src_install_all() {
dosym bzgrep /usr/bin/${x}
done
- dosym bzip2.1 /usr/share/man/man1/bzip2recover.1
+ dosym bzip2-reference.1 /usr/share/man/man1/bzip2recover.1
- local DOCS=( AUTHORS NEWS{,-pre-1.0.7} README.md )
einstalldocs
}