summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/createrepo')
-rw-r--r--app-arch/createrepo/createrepo-0.10.4.ebuild25
-rw-r--r--app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch4
2 files changed, 12 insertions, 17 deletions
diff --git a/app-arch/createrepo/createrepo-0.10.4.ebuild b/app-arch/createrepo/createrepo-0.10.4.ebuild
index afe57b3a0db7..1aa19ead5b54 100644
--- a/app-arch/createrepo/createrepo-0.10.4.ebuild
+++ b/app-arch/createrepo/createrepo-0.10.4.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='xml'
-inherit python-single-r1 bash-completion-r1 eutils
+inherit python-single-r1 bash-completion-r1
DESCRIPTION="Creates a common rpm-metadata repository"
HOMEPAGE="http://createrepo.baseurl.org/"
-SRC_URI="http://createrepo.baseurl.org/download/${P}.tar.gz
- https://dev.gentoo.org/~pacho/maintainer-needed/${PN}-0.9.9-head.patch.bz2"
+SRC_URI="http://createrepo.baseurl.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -28,28 +27,24 @@ RDEPEND=">=dev-python/urlgrabber-2.9.0[${PYTHON_USEDEP}]
${PYTHON_DEPS}"
DEPEND="${PYTHON_DEPS}"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.3-ten-changelog-limit.patch"
+)
pkg_setup() {
python-single-r1_pkg_setup
python_export PYTHON_SITEDIR
}
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.10.3-ten-changelog-limit.patch"
-}
-
-src_compile() {
- :
-}
-
src_install() {
emake install \
DESTDIR="${ED}" \
PYTHON=true \
compdir="$(get_bashcompdir)" \
PKGDIR="${PYTHON_SITEDIR}/${PN}"
- dodoc ChangeLog README
+ einstalldocs
python_fix_shebang "${ED}"
python_optimize
python_optimize "${ED}/usr/share/createrepo"
diff --git a/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch b/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch
index 07b61067462e..e6de1e11002f 100644
--- a/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch
+++ b/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch
@@ -1,5 +1,5 @@
---- createrepo/__init__.py~ 2011-01-26 12:14:30.000000000 -0500
-+++ createrepo/__init__.py 2011-01-26 12:34:17.291441719 -0500
+--- a/createrepo/__init__.py 2011-01-26 12:14:30.000000000 -0500
++++ b/createrepo/__init__.py 2011-01-26 12:34:17.291441719 -0500
@@ -96,7 +96,7 @@
self.mdtimestamp = 0
self.directory = None