summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dpkg/dpkg-1.19.0.5.ebuild')
-rw-r--r--app-arch/dpkg/dpkg-1.19.0.5.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/app-arch/dpkg/dpkg-1.19.0.5.ebuild b/app-arch/dpkg/dpkg-1.19.0.5.ebuild
deleted file mode 100644
index 8e4d1b70a04d..000000000000
--- a/app-arch/dpkg/dpkg-1.19.0.5.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils multilib autotools ltprune toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="https://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-lang/perl-5.14.2:=
- bzip2? ( app-arch/bzip2 )
- lzma? ( app-arch/xz-utils )
- selinux? ( sys-libs/libselinux )
- zlib? ( >=sys-libs/zlib-1.1.4 )
-"
-DEPEND="
- ${RDEPEND}
- app-arch/xz-utils
- sys-devel/flex
- virtual/pkgconfig
- nls? (
- app-text/po4a
- >=sys-devel/gettext-0.18.2
- )
- test? (
- dev-perl/IO-String
- dev-perl/Test-Pod
- virtual/perl-Test-Harness
- )
-"
-
-DOCS=(
- ChangeLog
- THANKS
- TODO
-)
-PATCHES=(
- "${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
- "${FILESDIR}"/${PN}-1.18.12-flags.patch
- "${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
-)
-
-src_prepare() {
- use nls && strip-linguas -i po
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable nls) \
- $(use_enable unicode) \
- $(use_enable update-alternatives) \
- $(use_with bzip2 libbz2) \
- $(use_with lzma liblzma) \
- $(use_with selinux libselinux) \
- $(use_with zlib libz) \
- --disable-compiler-warnings \
- --disable-dselect \
- --disable-start-stop-daemon \
- --localstatedir="${EPREFIX}"/var \
- --without-libmd
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
-
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-
- prune_libtool_files
-}