summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/innoextract/files')
-rw-r--r--app-arch/innoextract/files/innoextract-1.2-gentoo.patch49
-rw-r--r--app-arch/innoextract/files/innoextract-1.3-gentoo.patch49
-rw-r--r--app-arch/innoextract/files/innoextract-1.4-cmake.patch30
3 files changed, 128 insertions, 0 deletions
diff --git a/app-arch/innoextract/files/innoextract-1.2-gentoo.patch b/app-arch/innoextract/files/innoextract-1.2-gentoo.patch
new file mode 100644
index 000000000000..756f089a579e
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.2-gentoo.patch
@@ -0,0 +1,49 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Jun 27 23:41:12 UTC 2012
+Subject: build system
+
+respect flags
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -54,40 +54,13 @@
+ link_directories("${Boost_LIBRARY_DIRS}")
+ include_directories(SYSTEM "${Boost_INCLUDE_DIR}")
+
+-add_cxxflag("-Wall")
+-add_cxxflag("-Wextra")
+-add_cxxflag("-Wformat=2")
+-add_cxxflag("-Wundef")
+-add_cxxflag("-Wpointer-arith")
+-add_cxxflag("-Wcast-qual")
+-add_cxxflag("-Woverloaded-virtual")
+-add_cxxflag("-Wlogical-op")
+-add_cxxflag("-Wliteral-conversion")
+-add_cxxflag("-Wshift-overflow")
+-add_cxxflag("-Woverflow")
+-add_cxxflag("-Wbool-conversions")
+-add_cxxflag("-Wconversion")
+-add_cxxflag("-Wsign-conversion")
+-add_cxxflag("-Wmissing-declarations")
+-add_cxxflag("-Wredundant-decls")
+-
+ if(DEBUG_EXTRA)
+ add_cxxflag("-ftrapv") # to add checks for (undefined) signed integer overflow
+ add_cxxflag("-fbounds-checking")
+ add_cxxflag("-fcatch-undefined-behavior")
+ add_cxxflag("-Wstrict-aliasing=1")
+-else()
+- # -Wuninitialized causes too many false positives - thanks very much, gcc
+- add_cxxflag("-Wno-uninitialized")
+- # (clang only) Conflicts with using const variables for configuration.
+- add_cxxflag("-Wno-constant-logical-operand")
+- add_cxxflag("-Wno-unneeded-internal-declaration")
+- add_cxxflag("-Wno-unused-function")
+ endif()
+
+-# Because i'm lazy
+-add_cxxflag("-Wl,--as-needed")
+-
+ check_symbol_exists(isatty "unistd.h" HAVE_ISATTY)
+ check_symbol_exists(ioctl "sys/ioctl.h" HAVE_IOCTL)
+
diff --git a/app-arch/innoextract/files/innoextract-1.3-gentoo.patch b/app-arch/innoextract/files/innoextract-1.3-gentoo.patch
new file mode 100644
index 000000000000..31f7e9088ec7
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.3-gentoo.patch
@@ -0,0 +1,49 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Jul 3 18:00:33 UTC 2012
+Subject: build system
+
+respect flags
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -57,40 +57,13 @@
+
+ add_cxxflag("-std=c++11")
+
+-add_cxxflag("-Wall")
+-add_cxxflag("-Wextra")
+-add_cxxflag("-Wformat=2")
+-add_cxxflag("-Wundef")
+-add_cxxflag("-Wpointer-arith")
+-add_cxxflag("-Wcast-qual")
+-add_cxxflag("-Woverloaded-virtual")
+-add_cxxflag("-Wlogical-op")
+-add_cxxflag("-Wliteral-conversion")
+-add_cxxflag("-Wshift-overflow")
+-add_cxxflag("-Woverflow")
+-add_cxxflag("-Wbool-conversions")
+-add_cxxflag("-Wconversion")
+-add_cxxflag("-Wsign-conversion")
+-add_cxxflag("-Wmissing-declarations")
+-add_cxxflag("-Wredundant-decls")
+-
+ if(DEBUG_EXTRA)
+ add_cxxflag("-ftrapv") # to add checks for (undefined) signed integer overflow
+ add_cxxflag("-fbounds-checking")
+ add_cxxflag("-fcatch-undefined-behavior")
+ add_cxxflag("-Wstrict-aliasing=1")
+-else()
+- # -Wuninitialized causes too many false positives - thanks very much, gcc
+- add_cxxflag("-Wno-uninitialized")
+- # (clang only) Conflicts with using const variables for configuration.
+- add_cxxflag("-Wno-constant-logical-operand")
+- add_cxxflag("-Wno-unneeded-internal-declaration")
+- add_cxxflag("-Wno-unused-function")
+ endif()
+
+-# Because i'm lazy
+-add_ldflag("-Wl,--as-needed")
+-
+ check_symbol_exists(isatty "unistd.h" HAVE_ISATTY)
+ check_symbol_exists(ioctl "sys/ioctl.h" HAVE_IOCTL)
+
diff --git a/app-arch/innoextract/files/innoextract-1.4-cmake.patch b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
new file mode 100644
index 000000000000..199a10e14fac
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.4-cmake.patch
@@ -0,0 +1,30 @@
+--- innoextract-1.4/CMakeLists.txt
++++ innoextract-1.4/CMakeLists.txt
+@@ -6,6 +6,7 @@
+ # Define configuration options
+
+ option(USE_LZMA "Build lzma decompression support." ON)
++option(WITH_DEBUG "Debug build" OFF)
+ option(DEBUG_EXTRA "Expensive debug options" OFF)
+ option(SET_WARNING_FLAGS "Adjust compiler warning flags" ON)
+ option(SET_OPTIMIZATION_FLAGS "Adjust compiler optimization flags" ON)
+--- innoextract-1.4/cmake/BuildType.cmake
++++ innoextract-1.4/cmake/BuildType.cmake
+@@ -8,7 +8,7 @@
+ if(CMAKE_BUILD_TYPE STREQUAL "")
+ set(CMAKE_BUILD_TYPE "Release")
+ endif()
+-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+ add_definitions(-DDEBUG)
+ set(DEBUG 1)
+ endif()
+@@ -64,7 +64,7 @@
+ # Specifically, the need for libboost_system depends on the Boost version
+ add_ldflag("-Wl,--as-needed")
+
+- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++ if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR WITH_DEBUG)
+
+ # set debug symbol level to -g3
+ check_compiler_flag(RESULT "-g3")