summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lziprecover/lziprecover-1.23.ebuild')
-rw-r--r--app-arch/lziprecover/lziprecover-1.23.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/lziprecover/lziprecover-1.23.ebuild b/app-arch/lziprecover/lziprecover-1.23.ebuild
new file mode 100644
index 000000000000..cd4f742fd89c
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.23.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for lzip compressed files"
+HOMEPAGE="https://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}