summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/torrentzip/torrentzip-0.9-r1.ebuild')
-rw-r--r--app-arch/torrentzip/torrentzip-0.9-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/torrentzip/torrentzip-0.9-r1.ebuild b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
new file mode 100644
index 000000000000..ad564eefcc4c
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=(README AUTHORS)
+
+PATCHES=("${FILESDIR}/${P}-autoconf-quote.patch")
+
+src_prepare() {
+ default
+ export CPPFLAGS+=" -DOF\\(args\\)=args"
+ eautoreconf
+}