summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/Manifest3
-rw-r--r--app-arch/torrentzip/files/fix-perms.patch11
-rw-r--r--app-arch/torrentzip/files/torrentzip-0.2-fix-function-declarations.patch (renamed from app-arch/torrentzip/files/fix-function-declarations.patch)0
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r1.ebuild37
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r2.ebuild42
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r9.ebuild37
6 files changed, 43 insertions, 87 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
index 9f8b30682bad..09183004e480 100644
--- a/app-arch/torrentzip/Manifest
+++ b/app-arch/torrentzip/Manifest
@@ -1,2 +1 @@
-DIST trrntzip-code-9.zip 69200 SHA256 fe205b707af53f1bc90b03af3c07e56b08758ba52e42a9ef6780c8b297a129a6 SHA512 f848871ca14519539f141134f9bb1728ad30e9e6c33fe01677fa8542fbe7a0d8e9e58cf97ced6949b72ae9b59d09fd6ccbae1394295a17ffd78e53c96247497f WHIRLPOOL 4ccafe1f821b8e4016cccb9cbe2f755b57bc1ab301d94f92823c2ffc6b776639cf63c6072281273d0d3739d1c4dab09bc6cbb61b25249ac0ec4824be7628f726
-DIST trrntzip_v02_src.tar.gz 46971 SHA256 9e55f378ef5c75c452b3f52728a7503ca76e147e0ab2395b8c41de8c20995efd SHA512 802dd1bf55e0a31df75d8195c9d2d5610be8cb7f14d14278eba72b580aff3ad415711999db05a5425303380ebfc82a68896e276319e0ead5635d0a07615ba700 WHIRLPOOL 79c96f51a0b547b2651625a3b3aee6b7a769955e10b092654086a1d91a494d08f8dd732eee45b432ca97f4f6314af0f76907fa81b422ef94676e6d729994a61d
+DIST torrentzip-0.2.zip 69200 SHA256 3aa58e839743eebd97071e36585bb14cab0bddd22db646eb0765e1ae3ef2c749 SHA512 a6d6452940ab9070b96d598c7db306657afa34c3630160943260e6687e65985aa5aa8ad0b1319ee6470912207d6ef369fdb1168d5d528e8efd7405dc7722b1b8 WHIRLPOOL 0cad9f83e2d27795014be51b912d34350a59ad9c824f66237e1f15641daad812c92a7d5c6357e8d6a2517f08a381705f4eb057dc855700b007b99f3210046a1c
diff --git a/app-arch/torrentzip/files/fix-perms.patch b/app-arch/torrentzip/files/fix-perms.patch
deleted file mode 100644
index ea013663443f..000000000000
--- a/app-arch/torrentzip/files/fix-perms.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/trrntzip.c
-+++ src/trrntzip.c
-@@ -782,7 +782,7 @@
-
- if (strstr (szTmpBuf, ".zip\0") && !(istat.st_mode & S_IWUSR))
- {
-- chmod (direntp->d_name, S_IWUSR);
-+ chmod (direntp->d_name, S_IWUSR | S_IRUSR);
- mig.cEncounteredZips++;
-
- if (!mig.fProcessLog)
diff --git a/app-arch/torrentzip/files/fix-function-declarations.patch b/app-arch/torrentzip/files/torrentzip-0.2-fix-function-declarations.patch
index c8ab8fcd8930..c8ab8fcd8930 100644
--- a/app-arch/torrentzip/files/fix-function-declarations.patch
+++ b/app-arch/torrentzip/files/torrentzip-0.2-fix-function-declarations.patch
diff --git a/app-arch/torrentzip/torrentzip-0.2-r1.ebuild b/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
deleted file mode 100644
index 41d5f4b21d3d..000000000000
--- a/app-arch/torrentzip/torrentzip-0.2-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit versionator eutils autotools
-
-DESCRIPTION="Archiver that creates standard zips to create identical files over multiple systems"
-HOMEPAGE="https://sourceforge.net/projects/trrntzip"
-
-MY_PN=trrntzip
-MY_PV="$(replace_version_separator 1 '')"
-MY_P=${MY_PN}_v${MY_PV}
-S="${WORKDIR}"/${MY_PN}
-
-SRC_URI="mirror://sourceforge/trrntzip/${MY_P}_src.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="sys-libs/zlib"
-RDEPEND=""
-
-S=${WORKDIR}/trrntzip
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/fix-perms.patch
-
- eautoreconf
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc README AUTHORS
-}
diff --git a/app-arch/torrentzip/torrentzip-0.2-r2.ebuild b/app-arch/torrentzip/torrentzip-0.2-r2.ebuild
new file mode 100644
index 000000000000..e3cfa1a7da32
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_PN="trrntzip"
+MY_PV="code-9"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Advanced archiver to create identical files over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="http://sourceforge.net/code-snapshots/svn/t/tr/${MY_PN}/code/${MY_P}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-function-declarations.patch"
+)
+
+src_prepare() {
+ # Source-code from sf.net snapshots has CRLF...
+ EPATCH_OPTS="--binary"
+
+ epatch "${PATCHES[@]}"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ nonfatal dodoc README AUTHORS
+}
diff --git a/app-arch/torrentzip/torrentzip-0.2-r9.ebuild b/app-arch/torrentzip/torrentzip-0.2-r9.ebuild
deleted file mode 100644
index 01917e79cb51..000000000000
--- a/app-arch/torrentzip/torrentzip-0.2-r9.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator eutils autotools
-
-DESCRIPTION="Archiver that creates standard zips to create identical files over multiple systems"
-HOMEPAGE="https://sourceforge.net/projects/trrntzip"
-
-S="${WORKDIR}/trrntzip-code-9"
-
-SRC_URI="http://sourceforge.net/code-snapshots/svn/t/tr/trrntzip/code/trrntzip-code-9.zip"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="sys-libs/zlib"
-RDEPEND=""
-
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Source-code from sf.net snapshots has CRLF...
- EPATCH_OPTS="--binary"
- epatch "${FILESDIR}"/fix-function-declarations.patch
-
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- nonfatal dodoc README AUTHORS
-}