summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.14.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index b508bad0f5e4..60092e56e2a1 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.13.tar.gz 1079259 BLAKE2B c824e81182a6105d24fe85d148fb7e71c2ae761948421bacf7af240e4b2a381582ab5db46c29ee3b2daf01f710696ee53a93a0a2923923083c177e9473bee4f1 SHA512 ace6b3bade20f517c63a035022944d092868e4c000976ef388a3ee70ef8a28177ee20cfb089d0984e9274722c4ec13d129fd7a4ef542e7b5cd4423c26ad5b849
+DIST xarchiver-0.5.4.14.tar.gz 1081542 BLAKE2B 591d93dfbaa98164bc169105462155b09ed87dab8ad5adff6653e77673095a29d7f00cdaeed1b928039fe3cc5f668f8da46885905ae73d03f5b4c71dd279a7b4 SHA512 b38881e6cdfb402499efbd18ab25cac3869cd48ef96941a4bb3cb8b6b130a2317abe3b1d11bfc3d60e81eef7cafa34515fefc11e469443d96d139c2f09cf4498
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.14.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.14.ebuild
new file mode 100644
index 000000000000..12127f58d602
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# older pigz versions have incompatible command-line processing
+# https://bugs.gentoo.org/661464
+RDEPEND=">=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+ !!<app-arch/pigz-2.4[symlink]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ sed -e '/COPYING/d' -e '/NEWS/d' -i doc/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/unarj app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}