summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xar/xar-1.8-r3.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-arch/xar/xar-1.8-r3.ebuild b/app-arch/xar/xar-1.8-r3.ebuild
index 17416980f251..2b1ae6a93b9c 100644
--- a/app-arch/xar/xar-1.8-r3.ebuild
+++ b/app-arch/xar/xar-1.8-r3.ebuild
@@ -45,6 +45,12 @@ src_prepare() {
# strip RPATH pointing to ED
cd "${S}"/src || die
sed -i -e 's/@RPATH@//' Makefile.inc.in || die
+
+ # avoid GNU make (bug?) behaviour of removing xar.o as intermediate
+ # file, this doesn't happen outside portage, but it does from the
+ # ebuild env, causing the install phase to re-compile xar.o and link
+ # the executable
+ echo ".PRECIOUS: @objroot@src/%.o" >> Makefile.inc.in || die
}
multilib_src_configure() {