summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libpar2/libpar2-0.4.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-arch/libpar2/libpar2-0.4.ebuild b/app-arch/libpar2/libpar2-0.4.ebuild
index 6408f5475665..31de2a7569ff 100644
--- a/app-arch/libpar2/libpar2-0.4.ebuild
+++ b/app-arch/libpar2/libpar2-0.4.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit autotools-utils flag-o-matic
+EAPI=7
DESCRIPTION="A library for par2, extracted from par2cmdline"
HOMEPAGE="https://launchpad.net/libpar2/"
@@ -12,18 +10,18 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="static-libs"
RDEPEND="dev-libs/libsigc++:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS=( AUTHORS ChangeLog README )
+src_configure() {
+ econf --disable-static
+}
-# Needed to install all headers properly (bug #391815)
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_install() {
+ default
-src_prepare() {
- autotools-utils_src_prepare
- append-cxxflags -std=c++11 #567498
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}