summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/borgbackup/borgbackup-1.1.13.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.13.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.1.13.ebuild b/app-backup/borgbackup/borgbackup-1.1.13.ebuild
deleted file mode 100644
index 7867c0219e0c..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.13.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}