summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/amanda/amanda-3.5-r1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-backup/amanda/amanda-3.5-r1.ebuild b/app-backup/amanda/amanda-3.5-r1.ebuild
index 673a7b70daee..bbc32ece405d 100644
--- a/app-backup/amanda/amanda-3.5-r1.ebuild
+++ b/app-backup/amanda/amanda-3.5-r1.ebuild
@@ -481,4 +481,13 @@ amanda_permissions_fix() {
chown root:${AMANDA_GROUP_NAME} "${root}"/${i} || die
chmod u=srwx,g=rx,o= "${root}"/${i} || die
done
+
+ # amanda-security.conf is a config file with similar requirements:
+ # writable only by root
+ # world-readable
+ # 3.3.9: introduced in /etc/amanda-security.conf
+ # 3.4.2: moved to /etc/amanda/amanda-security.conf
+ f=/etc/amanda/amanda-security.conf
+ chown root:root "${root}""${f}" || die
+ chmod u=rw,go=r "${root}""${f}" || die
}