summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/dbench/dbench-4.0.ebuild')
-rw-r--r--app-benchmarks/dbench/dbench-4.0.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-benchmarks/dbench/dbench-4.0.ebuild b/app-benchmarks/dbench/dbench-4.0.ebuild
index 25861794037f..68746d46b4a0 100644
--- a/app-benchmarks/dbench/dbench-4.0.ebuild
+++ b/app-benchmarks/dbench/dbench-4.0.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils autotools toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Popular filesystem benchmark"
SRC_URI="https://www.samba.org/ftp/pub/tridge/dbench/${P}.tar.gz"
HOMEPAGE="https://www.samba.org/ftp/tridge/dbench/"
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~arm64 hppa ppc ppc64 sparc x86"
-IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
DEPEND="dev-libs/popt"
RDEPEND="${DEPEND}"
src_prepare() {
- eautoheader
- eautoconf
- sed -i -e \
- "s:\$(CC) -o:\$(CC) \$(LDFLAGS) -o:" \
- Makefile.in || die
+ default
+
+ sed -i -e "s:\$(CC) -o:\$(CC) \$(LDFLAGS) -o:" Makefile.in || die
+ mv configure.{in,ac} || die
+
eautoreconf
}
@@ -38,5 +38,5 @@ src_install() {
}
pkg_postinst() {
- elog "You can find the client.txt file in ${ROOT}usr/share/dbench."
+ elog "You can find the client.txt file in ${EROOT}/usr/share/dbench."
}