summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping/ioping-1.0.ebuild')
-rw-r--r--app-benchmarks/ioping/ioping-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/ioping-1.0.ebuild b/app-benchmarks/ioping/ioping-1.0.ebuild
new file mode 100644
index 000000000000..bf918199d332
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/ioping/archive/v1.0.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ default
+ sed \
+ -e 's:LICENSE::g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}