summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/sysbench/sysbench-1.0.15.ebuild')
-rw-r--r--app-benchmarks/sysbench/sysbench-1.0.15.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/app-benchmarks/sysbench/sysbench-1.0.15.ebuild b/app-benchmarks/sysbench/sysbench-1.0.15.ebuild
deleted file mode 100644
index bfd38a45f437..000000000000
--- a/app-benchmarks/sysbench/sysbench-1.0.15.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools pax-utils
-
-DESCRIPTION="System performance benchmark"
-HOMEPAGE="https://github.com/akopytov/sysbench"
-SRC_URI="https://github.com/akopytov/sysbench/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aio mysql postgres test"
-
-RDEPEND="aio? ( dev-libs/libaio )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- dev-lang/luajit:="
-DEPEND="${RDEPEND}
- dev-libs/concurrencykit
- dev-libs/libxslt
- sys-devel/libtool
- virtual/pkgconfig
- test? ( dev-util/cram )"
-
-src_prepare() {
- default
-
- # remove bundled libs
- rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable aio)
- $(use_with mysql)
- $(use_with postgres pgsql)
- --without-attachsql
- --without-drizzle
- --without-oracle
- --with-system-luajit
- --with-system-ck
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check test
-}
-
-src_install() {
- default
-
- pax-mark m "${ED%/}"/usr/bin/${PN}
-}