summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/kcdemu/kcdemu-0.7.2.ebuild')
-rw-r--r--app-cdr/kcdemu/kcdemu-0.7.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-cdr/kcdemu/kcdemu-0.7.2.ebuild b/app-cdr/kcdemu/kcdemu-0.7.2.ebuild
new file mode 100644
index 000000000000..cd1f4892e286
--- /dev/null
+++ b/app-cdr/kcdemu/kcdemu-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="kde_cdemu"
+inherit kde5
+
+DESCRIPTION="Frontend to cdemu daemon based on KDE Frameworks"
+HOMEPAGE="https://www.linux-apps.com/p/998461/"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1481242372/${MY_PN}-${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ >=app-cdr/cdemu-2.0.0[cdemu-daemon]
+ !app-cdr/kcdemu:4
+"
+
+S=${WORKDIR}/${MY_PN}