summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild b/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
deleted file mode 100644
index 3ef09260e724..000000000000
--- a/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
- S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
- >=app-crypt/certbot-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-augeas[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- esetup.py test || die
-}