summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-2.1.1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.1.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-2.1.1.ebuild b/app-crypt/certbot-apache/certbot-apache-2.1.1.ebuild
deleted file mode 100644
index 4d1707d36f00..000000000000
--- a/app-crypt/certbot-apache/certbot-apache-2.1.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="${PN%-apache}"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- # Only for amd64, arm64 and x86 because of dev-python/python-augeas
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
-HOMEPAGE="
- https://github.com/certbot/certbot
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="
- >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- dev-python/python-augeas[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest